爱板网论坛

查看: 145|回复: 1

[原创] 【TYDE3.0 涂鸦智能 IoT开发板】程序下载与更换RBG灯

[复制链接]

10

主题

0

好友

2256

积分

进士

Rank: 5Rank: 5

  • TA的每日心情
    开心
    昨天 12:38
  • 签到天数: 594 天

    连续签到: 10 天

    [LV.9]以坛为家II

    发表于 2018-2-9 10:06:07 |显示全部楼层
       TYDE3.0 涂鸦智能 IoT开发板确认收到的是没有程序的,于是下载了DEMO彩灯程序,开始用STM32 ST-LINK Utility下载,然后LED1灯闪了,但是测试配置的时候RGB灯没反应,以为下载出错了,于是用Flash Loader Demo重新下载程序,可是现象一样

    2.jpg


    3.jpg

    下载.png

    IMG_20180209_090146.jpg


       于是下载了涂鸦智能APP,反复测试下,快连模式没成功,用热点模式,慢闪的情况下可以配置成功了。但是APP上显示开灯了,RGB灯没任何反应。仔细看RGB灯,怀疑灯是坏的。
    IMG_20180209_083946.jpg
    IMG_20180209_083949.jpg
      
        翻箱倒柜找到2颗RGB灯,对照原版的缺口换上去,再测试,咦,还是不亮啊?
    IMG_20180209_083954.jpg

    IMG_20180209_085320.jpg

    IMG_20180209_085528.jpg


         仔细对照板子和原理图检查,发现缺口标记应该右下角,因为原来的是坏的,不确定是因为原来的就焊错了还是我手上的脚位和原板子不一致?重新上电,APP上终于可以控制RGB灯亮了!
    IMG_20180209_090121.jpg

    IMG_20180209_090122.jpg

         一股满足感呵呵,就是有个小小的疑惑?没有下载程序,RGB灯是坏的,发板前都没有做过测试么?还是这一批板子是来
    考验大家的“能力”了……



    IMG_20180209_085530.jpg
    IMG_20180209_090139.jpg
    回复

    使用道具 举报

    4

    主题

    0

    好友

    215

    积分

    秀才

    Rank: 3Rank: 3

  • TA的每日心情
    开心
    2018-2-11 08:52
  • 签到天数: 17 天

    连续签到: 1 天

    [LV.4]偶尔看看III

    发表于 2018-2-9 10:24:36 |显示全部楼层
    测试我的板子也是这样,LED只有绿色是正常的
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    关闭

    站长推荐上一条 /5 下一条

    手机版|爱板网 |网站地图  

    GMT+8, 2018-2-26 07:27 , Processed in 0.282420 second(s), 14 queries , Memcache On.

    苏公网安备 32059002001056号

    Powered by Discuz!

    回顶部