查看: 242|回复: 2

[原创] 【UP-BOARD分享】之Ubuntu内核选择和QT安装

[复制链接]

7

主题

0

好友

1237

积分

进士

Rank: 5Rank: 5

  • TA的每日心情
    奋斗
    4 天前
  • 签到天数: 217 天

    连续签到: 1 天

    [LV.7]常住居民III

    发表于 2017-1-4 22:40:01 |显示全部楼层
    本帖最后由 michael_llh 于 2017-1-4 22:50 编辑

             更新内核的地方官网的说明有点错误,在这里给出更正的方法:
    1、查看系统中的内核版本,命令:grep menuentry /boot/grub/grub.cfg
    2、确认系统中已经安装了UP-Board的内核之后,修改默认的启动内核版本。
             命令:sudo vi /etc/default/grub(这里的编辑器可以自己选择,可以换成gedit)
             修改:GRUB_DEFAULT=”Advanced options for Ubuntu>Ubuntu, with Linux 4.2.0-3-upboard”
    3、完成之后更新grub,命令:sudo update-grub
             然后我们重启UP-Board之后就会默认选择为UP-board的内核了。当然这样子是保留之前的内核内容,官方中也建议了一种方法就是删除其他版本的内核只保留UP-Board的内核,这样就不需要进行上面的设置了。根据自己的需要进行选择不同的方法了。



             安装QT,QT作为一个上位机开发软件,可以利用C++进行开发或者是使用python进行开发,对于上位机的开发是非常方便的。这里我们来看下如何在UP-Board上面安装QT。

             首先我们需要下载QT的安装包,我们可以直接在QT的官网进行下载。
    地址:https://www.qt.io/download-open-source/#section-2
             因为QT是有商用的版本的,我们一般是选择OpenSource的版本。如果有网络的话就可以选择Online的安装版本,我一般习惯都是下载Offline的版本,不会受到网络的限制。
    图片1.png

             下载好了只好拷贝到U盘上面。然后拷贝到UP-board当中去。
    IMG_20170104_195920.jpg

             首选我们需要安装一下G++,使用命令:sudo apt-get install g++
             然后我们打开终端,进入到我们QT的目录中去,首先先查看下权限。
             命令:ls -l
    IMG_20170104_200725.jpg

             我们看到安装文件是没有执行权限的,所以利用chmod添加执行权限。
    IMG_20170104_200753.jpg

             然后我们就可以进行安装了,命令:./qt-opensource-linux-x64-5.7.0.run
    IMG_20170104_200857.jpg

             跳过登录和注册的问题,选择skip
    IMG_20170104_200918.jpg

             继续下一步,选择next
    IMG_20170104_200945.jpg

             选择安装位置,根据自己需要选择了。这里我默认。
    IMG_20170104_201007.jpg

             选择QT安装的内容,这里我不进行更改,可以看到QT5.7是没有QT Designer和Assistant的。
    IMG_20170104_201054.jpg

             接受License Agreement。

             选择install。
    IMG_20170104_201322.jpg

             正在安装。。。
    IMG_20170104_201337.jpg

             安装完成。
    IMG_20170104_201508.jpg

             直接Finish后会启动QT。
    IMG_20170104_201524.jpg

             打开啦!!!
    IMG_20170104_201550.jpg

             QT的配置:(解决的是qmake不能使用的问题)
             进入/usr/lib/x86_64-linux-gnu/qt-default/qtchooser。
    IMG_20170104_202259.jpg

             更改这个文件default.conf内容如下:
    IMG_20170104_202243.jpg

             测试一个工程!
             出现了两个错误,我们这里解决一下。
    IMG_20170104_201712.jpg


             错误原因是找不到OpenGL的库。
             解决方法就是安装相关的包就可以了。命令:sudo apt-get install libqt4-dev
             成功啦!


    IMG_20170104_203315.jpg



    IMG_20170104_201252.jpg
    回复

    使用道具 举报

    3

    主题

    1

    好友

    3381

    积分

    状元

    Rank: 6Rank: 6

  • TA的每日心情
    奋斗
    昨天 23:07
  • 签到天数: 778 天

    连续签到: 4 天

    [LV.10]以坛为家III

    发表于 2017-1-4 23:12:16 |显示全部楼层
    参考和学习
    回复

    使用道具 举报

    7

    主题

    0

    好友

    1237

    积分

    进士

    Rank: 5Rank: 5

  • TA的每日心情
    奋斗
    4 天前
  • 签到天数: 217 天

    连续签到: 1 天

    [LV.7]常住居民III

    发表于 2017-1-5 09:33:07 |显示全部楼层
    jwdxu2009 发表于 2017-1-4 23:12
    参考和学习

    谢谢支持!
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    关闭

    站长推荐上一条 /5 下一条

    手机版|爱板网 |网站地图  

    GMT+8, 2017-5-27 10:30 , Processed in 0.183847 second(s), 12 queries , Memcache On.

    苏公网安备 32059002001056号

    Powered by Discuz!

    回顶部